Xcode 15.0 with edge updates

Xcode 15.0 with edge updates

Stack ID: osx-xcode-15.0.x-edge

Current stack revision: v2024-04-17

Changelog Update history Get notified

This Bitrise stack contains the following software:

Languages and runtimes #

Ruby versions

  • 3.0.6
  • 3.0
  • 3.1.4
  • 3.1
  • 3.2.3
  • 3.2 (default)
  • 3.3.0
  • 3.3
  • 3

Ruby version aliases

  • 3 => 3.3.0
  • 3.0 => 3.0.6
  • 3.1 => 3.1.4
  • 3.2 => 3.2.3
  • 3.3 => 3.3.0

Go versions

  • 1.21.8
  • 1.21 (default)
  • 1.22.1
  • 1.22
  • 1

Go version aliases

  • 1 => 1.22.1
  • 1.21 => 1.21.8
  • 1.22 => 1.22.1

Node.js versions

  • 20.11.1
  • 20.11
  • 20 (default)
  • 21.6.2
  • 21.6
  • 21

Node.js version aliases

  • 20 => 20.11.1
  • 20.11 => 20.11.1
  • 21 => 21.6.2
  • 21.6 => 21.6.2
  • lts => 20.9.0

Java versions

  • system
  • 1.8
  • 1.8.0.392
  • 11.0 (set by /Users/vagrant/.jenv/version) (default)
  • 11.0.21
  • 17.0
  • 17.0.9
  • 21.0
  • 21.0.2
  • 8.0
  • temurin64-1.8.0.392
  • temurin64-11.0.21
  • temurin64-17.0.9
  • temurin64-21.0.2

Flutter versions

  • 3.7.12 (global)

Python

  • Python 2.7.18

Kotlin

  • Kotlin version 1.9.23-release-779 (JRE 11.0.21+9)

Simulators #

Available runtimes and devices:

iOS 15.5

Build version: 19F70

Devices:

  • Bitrise iOS default
  • iPhone 8 Plus
  • iPhone 11
  • iPhone 13 Pro
  • iPhone 13 Pro Max
  • iPhone 13 mini
  • iPhone 13
  • iPhone SE (3rd generation)
  • iPod touch (7th generation)
  • iPad Pro (9.7-inch)
  • iPad (9th generation)
  • iPad Pro (11-inch) (3rd generation)
  • iPad Pro (12.9-inch) (5th generation)
  • iPad Air (5th generation)
  • iPad mini (6th generation)
iOS 16.4

Build version: 20E247

Devices:

  • Bitrise iOS default
  • iPhone 8 Plus
  • iPhone 11
  • iPhone SE (3rd generation)
  • iPhone 14
  • iPhone 14 Plus
  • iPhone 14 Pro
  • iPhone 14 Pro Max
  • iPad Air (5th generation)
  • iPad (10th generation)
  • iPad mini (6th generation)
  • iPad Pro (11-inch) (4th generation)
  • iPad Pro (12.9-inch) (6th generation)
iOS 17.0

Build version: 21A342

Devices:

  • Bitrise iOS default
  • iPhone 11
  • iPhone SE (3rd generation)
  • iPhone 15
  • iPhone 15 Plus
  • iPhone 15 Pro
  • iPhone 15 Pro Max
  • iPad Air (5th generation)
  • iPad (10th generation)
  • iPad mini (6th generation)
  • iPad Pro (11-inch) (4th generation)
  • iPad Pro (12.9-inch) (6th generation)
iOS 17.2

Build version: 21C62

Devices:

  • Bitrise iOS default
  • iPhone 11
  • iPhone SE (3rd generation)
  • iPhone 15
  • iPhone 15 Plus
  • iPhone 15 Pro
  • iPhone 15 Pro Max
  • iPad Air (5th generation)
  • iPad (10th generation)
  • iPad mini (6th generation)
  • iPad Pro (11-inch) (4th generation)
  • iPad Pro (12.9-inch) (6th generation)
iOS 17.4

Build version: 21E213

Devices:

  • Bitrise iOS default
  • iPhone 11
  • iPhone SE (3rd generation)
  • iPhone 15
  • iPhone 15 Plus
  • iPhone 15 Pro
  • iPhone 15 Pro Max
  • iPad Air (5th generation)
  • iPad (10th generation)
  • iPad mini (6th generation)
  • iPad Pro (11-inch) (4th generation)
  • iPad Pro (12.9-inch) (6th generation)
iOS 17.5

Build version: 21F5058d

Devices:

  • Bitrise iOS default
  • iPhone 11
  • iPhone SE (3rd generation)
  • iPhone 15
  • iPhone 15 Plus
  • iPhone 15 Pro
  • iPhone 15 Pro Max
  • iPad Air (5th generation)
  • iPad (10th generation)
  • iPad mini (6th generation)
  • iPad Pro (11-inch) (4th generation)
  • iPad Pro (12.9-inch) (6th generation)
tvOS 17.0

Build version: 21J353

Devices:

  • Apple TV
  • Apple TV 4K (3rd generation)
  • Apple TV 4K (3rd generation) (at 1080p)
tvOS 17.2

Build version: 21K364

Devices:

  • Apple TV
  • Apple TV 4K (3rd generation)
  • Apple TV 4K (3rd generation) (at 1080p)
tvOS 17.4

Build version: 21L224

Devices:

  • Apple TV
  • Apple TV 4K (3rd generation)
  • Apple TV 4K (3rd generation) (at 1080p)
tvOS 17.5

Build version: 21L5553e

Devices:

  • Apple TV
  • Apple TV 4K (3rd generation)
  • Apple TV 4K (3rd generation) (at 1080p)
watchOS 9.4

Build version: 20T253

Devices:

  • Apple Watch Series 5 (40mm)
  • Apple Watch Series 5 (44mm)
  • Apple Watch Series 6 (40mm)
  • Apple Watch Series 6 (44mm)
  • Apple Watch Series 7 (41mm)
  • Apple Watch Series 7 (45mm)
  • Apple Watch SE (40mm) (2nd generation)
  • Apple Watch SE (44mm) (2nd generation)
  • Apple Watch Series 8 (41mm)
  • Apple Watch Series 8 (45mm)
  • Apple Watch Ultra (49mm)
watchOS 10.0

Build version: 21R355

Devices:

  • Apple Watch Series 5 (40mm)
  • Apple Watch Series 5 (44mm)
  • Apple Watch Series 6 (40mm)
  • Apple Watch Series 6 (44mm)
  • Apple Watch Series 7 (41mm)
  • Apple Watch Series 7 (45mm)
  • Apple Watch SE (40mm) (2nd generation)
  • Apple Watch SE (44mm) (2nd generation)
  • Apple Watch Series 9 (41mm)
  • Apple Watch Series 9 (45mm)
  • Apple Watch Ultra 2 (49mm)
watchOS 10.2

Build version: 21S364

Devices:

  • Apple Watch Series 5 (40mm)
  • Apple Watch Series 5 (44mm)
  • Apple Watch Series 6 (40mm)
  • Apple Watch Series 6 (44mm)
  • Apple Watch Series 7 (41mm)
  • Apple Watch Series 7 (45mm)
  • Apple Watch SE (40mm) (2nd generation)
  • Apple Watch SE (44mm) (2nd generation)
  • Apple Watch Series 9 (41mm)
  • Apple Watch Series 9 (45mm)
  • Apple Watch Ultra 2 (49mm)
watchOS 10.4

Build version: 21T214

Devices:

  • Apple Watch Series 5 (40mm)
  • Apple Watch Series 5 (44mm)
  • Apple Watch Series 6 (40mm)
  • Apple Watch Series 6 (44mm)
  • Apple Watch Series 7 (41mm)
  • Apple Watch Series 7 (45mm)
  • Apple Watch SE (40mm) (2nd generation)
  • Apple Watch SE (44mm) (2nd generation)
  • Apple Watch Series 9 (41mm)
  • Apple Watch Series 9 (45mm)
  • Apple Watch Ultra 2 (49mm)
watchOS 10.5

Build version: 21T5555c

Devices:

  • Apple Watch Series 5 (40mm)
  • Apple Watch Series 5 (44mm)
  • Apple Watch Series 6 (40mm)
  • Apple Watch Series 6 (44mm)
  • Apple Watch Series 7 (41mm)
  • Apple Watch Series 7 (45mm)
  • Apple Watch SE (40mm) (2nd generation)
  • Apple Watch SE (44mm) (2nd generation)
  • Apple Watch Series 9 (41mm)
  • Apple Watch Series 9 (45mm)
  • Apple Watch Ultra 2 (49mm)
visionOS 1.0

Build version: 21N305

Devices:

  • Apple Vision Pro
visionOS 1.1

Build version: 21O209

Devices:

  • Apple Vision Pro
visionOS 1.2

Build version: 21O5565d

Devices:

  • Apple Vision Pro

CLI tools #

Apple development #

Xcode version
$ xcodebuild -version

Xcode 15.0.1 Build version 15A507
Swift (Xcode bundled)
$ xcrun swift --version

swift-driver version: 1.87.1 Apple Swift version 5.9 (swiftlang-5.9.0.128.108 clang-1500.0.40.1) Target: arm64-apple-macosx14.0
Active Xcode command line tools
$ xcode-select --print-path

/Applications/Xcode-15.0.1.app/Contents/Developer
swift-format - 510.1.0
$ swift-format --version

510.1.0
Tuist - 3.20.0
$ tuist version

3.20.0
Homebrew config
$ brew config

HOMEBREW_VERSION: 4.2.18 ORIGIN: https://github.com/Homebrew/brew HEAD: 9edabf02ce29e54d0b717baa757cff38ad0c0e25 Last commit: 3 days ago Core tap JSON: 17 Apr 06:56 UTC Core cask tap JSON: 17 Apr 06:56 UTC HOMEBREW_PREFIX: /opt/homebrew HOMEBREW_CASK_OPTS: ["--no-quarantine"] HOMEBREW_MAKE_JOBS: 5 HOMEBREW_NO_ANALYTICS: set HOMEBREW_NO_INSTALL_CLEANUP: set Homebrew Ruby: 3.1.4 => /opt/homebrew/Library/Homebrew/vendor/portable-ruby/3.1.4/bin/ruby CPU: 5-core 64-bit dunno Clang: 15.0.0 build 1500 Git: 2.44.0 => /opt/homebrew/bin/git Curl: 8.1.2 => /usr/bin/curl macOS: 14.1.2-arm64 CLT: 15.0.0.0.1.1694021235 Xcode: 15.0.1 => /Applications/Xcode-15.0.1.app/Contents/Developer Rosetta 2: false
Mint - 0.17.5
$ mint version

Version: 0.17.5
Cocoapods config
$ pod env

### Stack ``` CocoaPods : 1.15.2 Ruby : ruby 3.2.3 (2024-01-18 revision 52bb2ac0a6) [arm64-darwin23] RubyGems : 3.4.19 Host : macOS 14.1.2 (23B92) Xcode : 15.0.1 (15A507) Git : git version 2.39.3 (Apple Git-145) Ruby lib dir : /Users/vagrant/.asdf/installs/ruby/3.2.3/lib Repositories : master - git - https://github.com/CocoaPods/Specs.git @ 718f4f6bf896902196bff3b62e3c78d950939e8e trunk - CDN - https://cdn.cocoapods.org/ ``` ### Installation Source ``` Executable Path: /Users/vagrant/.asdf/installs/ruby/3.2/bin/pod ``` ### Plugins ``` cocoapods-deintegrate : 1.0.5 cocoapods-plugins : 1.0.0 cocoapods-search : 1.0.1 cocoapods-trunk : 1.6.0 cocoapods-try : 1.2.0 slather : 2.8.0 ```
Carthage - 0.39.1
$ carthage version

0.39.1
SwiftLint - 0.53.0
$ swiftlint version

0.53.0
xcpretty - 0.3.0
$ xcpretty --version

0.3.0
applesimutils - 0.9.10
$ applesimutils -v

applesimutils version 0.9.10
danger-swift - 3.18.0
$ danger-swift --version

3.18.0 
xcbeautify - 2.1.0
$ xcbeautify --version

2.1.0
xclogparser - 0.2.39
$ xclogparser version

XCLogParser 0.2.39

Android development #

Emulator version - 33.1.23
$ grep ^Pkg.Revision "${ANDROID_HOME}"/emulator/source.properties

Pkg.Revision=33.1.23
Gradle - 8.7
$ gradle --version

Welcome to Gradle 8.7! Here are the highlights of this release: - Compiling and testing with Java 22 - Cacheable Groovy script compilation - New methods in lazy collection properties For more details see https://docs.gradle.org/8.7/release-notes.html ------------------------------------------------------------ Gradle 8.7 ------------------------------------------------------------ Build time: 2024-03-22 15:52:46 UTC Revision: 650af14d7653aa949fce5e886e685efc9cf97c10 Kotlin: 1.9.22 Groovy: 3.0.17 Ant: Apache Ant(TM) version 1.10.13 compiled on January 4 2023 JVM: 11.0.21 (Eclipse Adoptium 11.0.21+9) OS: Mac OS X 14.1.2 aarch64
Maven - 3.9.6
$ mvn --version

Apache Maven 3.9.6 (bc0240f3c744dd6b6ec2920b3cd08dcc295161ae) Maven home: /opt/homebrew/Cellar/maven/3.9.6/libexec Java version: 11.0.21, vendor: Eclipse Adoptium, runtime: /Library/Java/JavaVirtualMachines/temurin-11.jdk/Contents/Home Default locale: en_US, platform encoding: UTF-8 OS name: "mac os x", version: "14.1.2", arch: "aarch64", family: "mac"
Ant - 1.10.14
$ ant -version

Apache Ant(TM) version 1.10.14 compiled on August 16 2023
Android SDK packages
  Path                                                                              | Version      | Description                        | Location                                                                         
  -------                                                                           | -------      | -------                            | -------                                                                          
  add-ons;addon-google_apis-google-24                                               | 1            | Google APIs                        | add-ons/addon-google_apis-google-24                                              
  build-tools;32.0.0                                                                | 32.0.0       | Android SDK Build-Tools 32         | build-tools/32.0.0                                                               
  build-tools;34.0.0                                                                | 34.0.0       | Android SDK Build-Tools 34         | build-tools/34.0.0                                                               
  cmake;3.10.2.4988404                                                              | 3.10.2       | CMake 3.10.2.4988404               | cmake/3.10.2.4988404                                                             
  cmake;3.22.1                                                                      | 3.22.1       | CMake 3.22.1                       | cmake/3.22.1                                                                     
  emulator                                                                          | 33.1.23      | Android Emulator                   | emulator                                                                         
  extras;google;google_play_services                                                | 49           | Google Play services               | extras/google/google_play_services                                               
  ndk-bundle                                                                        | 24.0.8215888 | Android NDK                        | ndk-bundle                                                                       
  platform-tools                                                                    | 34.0.5       | Android SDK Platform-Tools         | platform-tools                                                                   
  platforms;android-32                                                              | 1            | Android SDK Platform 32            | platforms/android-32                                                             
  platforms;android-33                                                              | 3            | Android SDK Platform 33            | platforms/android-33                                                             
  platforms;android-34                                                              | 2            | Android SDK Platform 34            | platforms/android-34                                                             

Generic tools #

Git - 2.39.3
$ git --version

git version 2.39.3 (Apple Git-145)
Git LFS - 3.5.1
$ git-lfs version

git-lfs/3.5.1 (GitHub; darwin arm64; go 1.22.1)
GitHub CLI - 2.47.0
$ gh --version

gh version 2.47.0 (2024-04-03) https://github.com/cli/cli/releases/tag/v2.47.0
jq - 1.7.1
$ jq --version

jq-1.7.1
AWS CLI - 2.15.38
$ aws --version

aws-cli/2.15.38 Python/3.11.9 Darwin/23.1.0 source/arm64 prompt/off
Dart global packages
$ dart pub global list

junitreport 2.0.2
Mercurial - 6.7.2
$ hg version

Mercurial Distributed SCM (version 6.7.2) (see https://mercurial-scm.org for more information) Copyright (C) 2005-2023 Olivia Mackall and others This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Firebase - 12.9.1
$ firebase --version

12.9.1
OpenConnect - 9.12
$ openconnect --version

OpenConnect version v9.12-unknown Using GnuTLS 3.8.3. Features present: PKCS#11, RSA software token, HOTP software token, TOTP software token, Yubikey OATH, System keys, DTLS, ESP Supported protocols: anyconnect (default), nc, gp, pulse, f5, fortinet, array Default vpnc-script (override with --script): /opt/homebrew/etc/vpnc/vpnc-script
CMake - 3.29.2
$ cmake --version

cmake version 3.29.2 CMake suite maintained and supported by Kitware (kitware.com/cmake).
OpenVPN - 2.6.10
$ openvpn --version

OpenVPN 2.6.10 aarch64-apple-darwin23.4.0 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [MH/RECVDA] [AEAD] library versions: OpenSSL 3.2.1 30 Jan 2024, LZO 2.10 Originally developed by James Yonan Copyright (C) 2002-2024 OpenVPN Inc <[email protected]> Compile time defines: enable_async_push=no enable_comp_stub=no enable_crypto_ofb_cfb=yes enable_dco=no enable_debug=no enable_dependency_tracking=no enable_dlopen=unknown enable_dlopen_self=unknown enable_dlopen_self_static=unknown enable_fast_install=needless enable_fragment=yes enable_iproute2=no enable_libtool_lock=yes enable_lz4=yes enable_lzo=yes enable_management=yes enable_pam_dlopen=no enable_pedantic=no enable_pkcs11=yes enable_plugin_auth_pam=yes enable_plugin_down_root=yes enable_plugins=yes enable_port_share=yes enable_selinux=no enable_shared=yes enable_shared_with_static_runtimes=no enable_silent_rules=no enable_small=no enable_static=yes enable_strict=no enable_strict_options=no enable_systemd=no enable_werror=no enable_win32_dll=yes enable_wolfssl_options_h=yes enable_x509_alt_username=no with_aix_soname=aix with_crypto_library=openssl with_gnu_ld=no with_mem_check=no with_openssl_engine=auto with_sysroot=no

Global NPM packages #

Global NPM packages
$ npm list -g --depth=0

/Users/vagrant/.asdf/installs/nodejs/20.11.1/lib ├── @ionic/[email protected] ├── [email protected] ├── [email protected] ├── [email protected] ├── [email protected] ├── [email protected] └── [email protected]

Bitrise-specific #

Bitrise CLI - 2.10.0
$ bitrise --version

2.10.0
Bitrise stepman - 0.16.1
$ stepman --version

0.16.1
Bitrise envman - 2.4.2
$ envman --version

2.4.2

Homebrew #

All packages
  • ant 1.10.14
  • aom 3.8.2
  • applesimutils 0.9.10
  • apr 1.7.4
  • apr-util 1.6.3_1
  • argon2 20190702_1
  • aria2 1.37.0
  • aspell 0.60.8.1_1
  • autoconf 2.72
  • awscli 2.15.38
  • bazelisk 1.19.0
  • boost 1.84.0_1
  • brotli 1.1.0
  • ca-certificates 2024-03-11
  • cairo 1.18.0
  • carthage 0.39.1
  • cffi 1.16.0_1
  • cmake 3.29.2
  • coreutils 9.5
  • curl 8.6.0
  • danger-js 64
  • danger-swift 3.18.0
  • dart 3.2.2
  • docutils 0.20.1_1
  • double-conversion 3.3.0
  • edencommon 2024.04.15.00
  • fb303 2024.04.15.00
  • fbthrift 2024.04.15.00
  • fizz 2024.04.15.00
  • flow 0.233.0
  • fmt 10.2.1_1
  • folly 2024.04.15.00
  • fontconfig 2.15.0
  • freetds 1.4.10
  • freetype 2.13.2
  • fvm 2.4.1
  • gd 2.3.3_6
  • gettext 0.22.5
  • gflags 2.2.2
  • gh 2.47.0
  • ghostscript 10.03.0
  • giflib 5.2.1
  • git 2.44.0
  • git-lfs 3.5.1
  • glib 2.80.0_2
  • glog 0.6.0
  • gmp 6.3.0
  • gnupg 2.4.5
  • gnutls 3.8.3
  • gradle 8.7
  • graphite2 1.3.14
  • groovy 4.0.21
  • harfbuzz 8.4.0
  • highway 1.1.0
  • hub 2.14.2
  • icu4c 74.2
  • imagemagick 7.1.1-30
  • imap-uw 2007f_1
  • imath 3.1.11
  • jasper 4.2.3
  • jbig2dec 0.20
  • jenv 0.5.6
  • jpeg-turbo 3.0.2
  • jpeg-xl 0.10.2
  • jq 1.7.1
  • kotlin 1.9.23
  • krb5 1.21.2
  • libassuan 2.5.7
  • libavif 1.0.4
  • libde265 1.0.15
  • libevent 2.1.12_1
  • libgcrypt 1.10.3
  • libgpg-error 1.48
  • libheif 1.17.6_1
  • libidn 1.42
  • libidn2 2.3.7
  • libksba 1.6.6
  • liblqr 0.4.2_1
  • libnghttp2 1.60.0
  • libomp 18.1.3
  • libpng 1.6.43
  • libpq 16.2_1
  • libraw 0.21.2
  • libsodium 1.0.19
  • libssh2 1.11.0_1
  • libtasn1 4.19.0
  • libtiff 4.6.0
  • libtool 2.4.7
  • libunistring 1.2
  • libusb 1.0.27
  • libvmaf 3.0.0
  • libx11 1.8.9
  • libxau 1.0.11
  • libxcb 1.16.1
  • libxdmcp 1.1.5
  • libxext 1.3.6
  • libxrender 0.9.11
  • libyaml 0.2.5
  • libzip 1.10.1
  • little-cms2 2.16
  • lokalise2 2.6.10
  • lz4 1.9.4
  • lzo 2.10
  • m4 1.4.19
  • maven 3.9.6
  • mercurial 6.7.2
  • mint 0.17.5
  • mpdecimal 4.0.0
  • nettle 3.9.1
  • npth 1.7
  • oniguruma 6.9.9
  • openconnect 9.12
  • openexr 3.2.4
  • openjdk 21.0.2
  • openjpeg 2.5.2
  • openldap 2.6.7
  • openssl@3 3.2.1
  • openvpn 2.6.10
  • p11-kit 0.25.3
  • parallel 20240322
  • pcre2 10.43
  • php 8.3.4
  • pinentry 1.2.1
  • pixman 0.42.2
  • pkcs11-helper 1.30.0
  • pkg-config 0.29.2_3
  • pycparser 2.21_1
  • pyenv 2.3.33
  • python-pathspec 0.12.1
  • python-setuptools 69.1.0
  • [email protected] 3.11.9
  • [email protected] 3.12.3
  • pyyaml 6.0.1_1
  • rbenv 1.2.0
  • readline 8.2.10
  • rtmpdump 2.4-20151223_3
  • ruby-build 20231114
  • screen 4.9.1
  • shared-mime-info 2.4
  • six 1.16.0_4
  • snappy 1.1.10
  • sonar-scanner 5.0.1.3006
  • sqlite 3.45.2
  • stoken 0.93
  • swift-format 510.1.0
  • swiftlint 0.53.0
  • tidy-html5 5.8.0
  • transcrypt 2.2.3
  • tree 2.1.1_1
  • unbound 1.19.2
  • unixodbc 2.3.12
  • wangle 2024.04.15.00
  • watchman 2024.04.15.00
  • webp 1.3.2
  • wget 1.24.5
  • x265 3.6
  • xcbeautify 2.1.0
  • xclogparser 0.2.39
  • xcodes 1.3.0
  • xorgproto 2024.1
  • xz 5.6.1
  • yamllint 1.35.1
  • yarn 1.22.22
  • zeromq 4.3.5_1
  • zstd 1.5.6
  • temurin11 11.0.21,9
  • temurin17 17.0.9,9
  • temurin21 21.0.2,13
  • temurin8 8,392,08

OS #

macOS system overview
$ system_profiler SPSoftwareDataType

Software: System Software Overview: System Version: macOS 14.1.2 (23B92) Kernel Version: Darwin 23.1.0 Boot Volume: Macintosh HD Boot Mode: Normal Computer Name: vm-osx-sonoma-15-edge-g2-m1-max.5core-75e34e8b-274e-4111-a0c5-3ce0bc65f452 User Name: vagrant (vagrant) Secure Virtual Memory: Enabled System Integrity Protection: Disabled Time since boot: 1 minute, 50 seconds
Disk space
$ df -h /

Filesystem Size Used Avail Capacity iused ifree %iused Mounted on /dev/disk2s1s1 309Gi 9.2Gi 99Gi 9% 390k 1.0G 0% /
OpenSSH
$ ssh -V

OpenSSH_9.4p1, LibreSSL 3.3.6